dhcpd on Solaris 10

Glenn Satchell Glenn.Satchell at uniq.com.au
Sat Apr 25 07:26:43 UTC 2009

What version of dhcpd are you using? I've had problems with 4.0.0. In
that case it works with a relay but not for directly attached
networks.  I haven't tried 4.1.0 yet. All of the 3.x versions work fine
with Solaris 10.

Otherwise can you post your dhcpd.conf.


>Date: Sat, 25 Apr 2009 07:08:41 +0200
>Subject: dhcpd on Solaris 10
>From: Jason Penton <jason.penton at gmail.com>
>To: dhcp-users at lists.isc.org
>X-BeenThere: dhcp-users at lists.isc.org
>Hi *,
>I am pulling my hair out trying to serve the simplest of setups using
>ISC dhcpd on Solaris 10.
>The problem is that the DISCOVERS come in.
>dhcpd responds with OFFER.
>Client never sends REQUEST.
>The exact same config on a linux box works as predicted.
>Packet trace of differences between the 2 OFFERS (sent by linux and
>Solaris) is that the Solaris offer has:
>server-ip-address set to,
>while linux,
>server-ip-address set to (x.x.x.x ip of dhcpd server)
>I have tried every option to get the solaris box to correctly set this
>option (even server-identifier) but to noavail.
>Could someone please shed some light?
>Kind regards
>dhcp-users mailing list
>dhcp-users at lists.isc.org

More information about the dhcp-users mailing list