dhcpd on Solaris 10

Glenn Satchell Glenn.Satchell at uniq.com.au
Sat Apr 25 12:18:44 UTC 2009

Hi Jason

With multiple interfaces the server-identifier changes depending upon
the interface. I would remove the two server-identifier statements,
typically they are not required, and the dhcp server fills in a
suitable value anyway. The only time the server-identifier is used is
if you have a virtual IP address on an interface (bge0:1 for example)
and you want requests to come back to that interface. The rest looks
pretty standard.

You can try running dhcp only using 1 nic by specifying the nic name on
the commandline, eg:

 dhcpd bge0

Might be worth trying to see if that makes any difference.


>Date: Sat, 25 Apr 2009 09:44:48 +0200
>Subject: Re: dhcpd on Solaris 10
>From: Jason Penton <jason.penton at gmail.com>
>To: Glenn Satchell <Glenn.Satchell at uniq.com.au>, Users of ISC DHCP 
<dhcp-users at lists.isc.org>
>Hi Glenn, *
>I've tried many version - in both release 3 and 4, but exactly the
>same symptoms. I've stripped down my dhcpd.conf to the bare minimum as
>server-identifier <dhcp server IP>;
>option dhcp-server-identifier <dhcp server IP>;
>option domain-name "domain.com";
>option domain-name-servers <DNS server IP>;
>default-lease-time 14440;
>ddns-update-style none;
>deny bootp;
>shared-network NetworkName {
>        subnet X.X.X.0 netmask {
>                option routers X.X.X.X;
>                option subnet-mask;
>                pool {
>                        range X.X.X.Y X.X.X.Z;
>                }
>        }
>Any help would be greatly appreciated.
>Another thing. The clients do get the OFFER but obv. dont respond
>because of the server-ip-address being
>BTW, DHCP server has 4 NICs configured (dont know if this has any effect)
>On Sat, Apr 25, 2009 at 9:26 AM, Glenn Satchell
><Glenn.Satchell at uniq.com.au> wrote:
>> What version of dhcpd are you using? I've had problems with 4.0.0. In
>> that case it works with a relay but not for directly attached
>> networks.  I haven't tried 4.1.0 yet. All of the 3.x versions work fine
>> with Solaris 10.
>> Otherwise can you post your dhcpd.conf.
>> regards,
>> -glenn
>>>Date: Sat, 25 Apr 2009 07:08:41 +0200
>>>Subject: dhcpd on Solaris 10
>>>From: Jason Penton <jason.penton at gmail.com>
>>>To: dhcp-users at lists.isc.org
>>>X-BeenThere: dhcp-users at lists.isc.org
>>>Hi *,
>>>I am pulling my hair out trying to serve the simplest of setups using
>>>ISC dhcpd on Solaris 10.
>>>The problem is that the DISCOVERS come in.
>>>dhcpd responds with OFFER.
>>>Client never sends REQUEST.
>>>The exact same config on a linux box works as predicted.
>>>Packet trace of differences between the 2 OFFERS (sent by linux and
>>>Solaris) is that the Solaris offer has:
>>>server-ip-address set to,
>>>while linux,
>>>server-ip-address set to (x.x.x.x ip of dhcpd server)
>>>I have tried every option to get the solaris box to correctly set this
>>>option (even server-identifier) but to noavail.
>>>Could someone please shed some light?
>>>Kind regards
>>>dhcp-users mailing list
>>>dhcp-users at lists.isc.org
>> _______________________________________________
>> dhcp-users mailing list
>> dhcp-users at lists.isc.org
>> https://lists.isc.org/mailman/listinfo/dhcp-users
>dhcp-users mailing list
>dhcp-users at lists.isc.org

More information about the dhcp-users mailing list