trouble compiling 4.1.0p1

David W. Hankins dhankins at
Mon Aug 10 22:45:42 UTC 2009

On Mon, Aug 10, 2009 at 09:16:11AM +1000, Glenn Satchell wrote:
> I've been using 4.1.1b1 since April with no problems (but it is only a
> small installation). In fact, no earlier version works properly on
> Solaris 10.

I thought 3.1.x works fine on Solaris?  For DHCPv6 we had to split up
"gathering the interface's MAC address" and "setting up raw sockets,"
so the bug was introduced in 4.0.0.

The code worked fine using DHCPv6, but DHCPv4 using DLPI failed to
gather a correct MAC address and would stop receiving packets when the
server tried to transmit a packet from a garbage MAC.

David W. Hankins	"If you don't do it right the first time,
Software Engineer		     you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
URL: <>

More information about the dhcp-users mailing list