Cannot get classes to work - what am I missing

Ski Kacoroski kacoroski at
Tue May 12 15:10:26 UTC 2009


I am running 3.0.4 on debian etch.  My dhcpd.conf file looks like:

class "nsdcomputers" {
   match option dhcp-client-identifier;

subclass "nsdcomputers" 1:00:1f:5b:c4:3e:0c;
subclass "nsdcomputers" 1:00:1f:f3:ce:30:59;
subclass "nsdcomputers" 1:00:1f:3c:1b:64:16;

subnet netmask {
   option subnet-mask;
   option broadcast-address;
   option routers;
   max-lease-time 28800;
   pool {
     allow members of "nsdcomputers";

Yet all I get is the error:

May 11 14:31:15 linux2 dhcpd: DHCPDISCOVER from 00:1f:5b:c4:3e:0c via network 10.180.191/24: no free leases

When I comment out the "allow members of..." clause it works.  I have
also tried using:

host skilx {
  option dhcp-client-identifier 1:00:1f:5b:c4:3e:0c;
  add "nsdcomputers";

instead of subclasses and get the same error.

Thanks in advance for your help.



"When we try to pick out anything by itself, we find it
 connected to the entire universe"            John Muir

Chris "Ski" Kacoroski, kacoroski at, 206-501-9803
or ski98033 on most IM services

More information about the dhcp-users mailing list