how to get slp-directory-agent option working

Matt Ashfield mda at
Tue Oct 13 16:37:57 UTC 2009



We are running an older version of DHCP (3.0.5). I have googled around and
can't come up with the right solution for this problem.


In our dhcpd.conf, we are globally defining:

option slp-directory-agent code 78 = { boolean, ip-address };

option slp-directory-agent false,;


However, this is never handed out to devices. A network sniff shows this.

A few things I have tried:

-          I have read where we have to have the server set as
authoritative. I have set this globally. I have also set that within the
subnet declaration and it still did not produce results.

-          I have tried setting the value of the slp-directory-agent within
the subnet declaration, and still no result.

-          I have tried not declaring the slp-directory-agent code 78 line,
(because from what I read, this should be pre-built into the DHCP server)
and it still did not work.

Any advice is greatly appreciated.




mda at


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the dhcp-users mailing list