CableLabs Vendor Specific Option not in Relay-Reply message

Cheng Ching-Ho-LCC014 Ching-Ho.Cheng at
Tue Oct 5 15:31:51 UTC 2010

Hi Patricio,
I just tried your suggestion with 4.1.1-P1 by moving the options from
global to local inside subnet6 definition.  I still got the same result:
relay-reply message from server did not contain CableLabs vendor
specific options.
I then tried 4.2.0 and got the same result as 4.1.1-P1.
Is there any new commands that I need to put in dhcpd6.conf in release
4.1.1-P1 and after to make server to insert vendor specific options in
relay-reply message back to relay agent ?
Ching-Ho Cheng


From: at
[ at] On Behalf
Of Patricio Latini
Sent: Sunday, October 03, 2010 4:20 PM
To: dhcp-users at
Subject: RE: CableLabs Vendor Specific Option not in Relay-Reply message

I think you should include the options within the subnet definition.
LIke the example below. That is working for me.

shared-network C4-IPV6-Bundle1 {
subnet6 FC00:0000:0000:0001::0/64 {
option docsis.tftp-servers FC00::1;
option docsis.cablelabs-configuration-file "arris-D30modem.bin";
option docsis.cablelabs-syslog-servers FC00::1;
option docsis.time-servers FC00::1;
option docsis.time-offset -10800;
option FC00::1;
range6 FC00:0000:0000:0001::/64;


Subject: RE: CableLabs Vendor Specific Option not in Relay-Reply message
Date: Thu, 30 Sep 2010 10:22:43 -0400
From: Ching-Ho.Cheng at
To: dhcp-users at

I have enclosed the dhcpd6.conf for reference.  I hope that this could
help to determine my DHCPv6 server problem :
#Define the options:
option space docsis code width 2 length width 2;
option vsio.docsis code 4491 = encapsulate docsis;
option docsis.tftp-servers code 32 = array of ip6-address;
option docsis.cablelabs-configuration-file code 33 = text;
option docsis.cablelabs-syslog-servers code 34 = array of ip6-address;
option docsis.device-id code 36 = string;
option docsis.time-servers code 37 = array of ip6-address;
option docsis.time-offset code 38 = signed integer 32;
#Configure global options:
option docsis.cablelabs-configuration-file "basic.bin";
option docsis.cablelabs-syslog-servers 2000:300::2;
option docsis.tftp-servers 2000:300::2;
option docsis.time-servers 2000:300::2;
option docsis.time-offset 0;
option dhcp6.rapid-commit;
# lease-time information: default = 30 minutes, max = 120 minutes
#default-lease-time 864000;
#max-lease-time 864000;
default-lease-time 1800;
max-lease-time 1800;
# modem configuration file name:
#filename "basic.bin";
ddns-update-style ad-hoc;
    subnet6 2000:300::/64 {
            range6 2000:300::/64;
# Goldie Subnet 
shared-network "goldie_1" {
        option docsis.cablelabs-configuration-file "goldie_1.bin";
        subnet6 2001:100:101::/64 {
                range6 2001:100:101::/64;

Ching-Ho Cheng


From: at
[ at] On Behalf
Of Cheng Ching-Ho-LCC014
Sent: Wednesday, September 29, 2010 2:01 PM
To: Users of ISC DHCP
Subject: CableLabs Vendor Specific Option not in Relay-Reply message

I upgraded the DHCP server to 4.1.x from 4.0.x. Now, in DHCPv6
relay-reply message from ISC server, there is no CableLabs vendor
specific options included. IPv6 modem could not register due to the
missing TFTP/config file information within the CableLabs vendor option.

I was using the same dhcpd6.conf as in 4.0.x. Any suggestion is

Ching-Ho Cheng
Motorola Inc.
Mobile Devices & Home
Phone: 508-786-7522

_______________________________________________ dhcp-users mailing list
dhcp-users at 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the dhcp-users mailing list