Logging DHCP3.1.3 in FreeBSD8.1

Martin McCormick martin at dc.cis.okstate.edu
Thu Oct 28 14:48:28 UTC 2010

	I just tried running dhcpd3.1.3 on a FreeBSD8.1
installation. It ran beautifully as far as I can tell, but there
is no syslog.

	I did touch /var/log/syslog and used chmod 644 to set it
to the right permissions and then restarted syslogd and
absolutely nothing happened.

	Newsyslog.conf sees the file and rolls it over at the
correct time and stamps the starting time for the new version of
syslog, but I can't get any logging of dhcp.

	One usually installs a line in syslog like:

 *.info;auth.info;mail.warning;cron.warning		/var/log/syslog

	I even wrote a tiny C executable that writes a critical
test message to the log. It shows up in /var/log/messages, but
not in /var/log/syslog.

Has anybody else had/solved this problem?

This may be more suitable for the FreeBSD discussion list, but
I have the question out there and have received no answers so

	This was a last-minute surprise while upgrading our dhcp
server to FreeBSD8.1 so we went back to the older box for now.

Many thanks.

	Martin McCormick

More information about the dhcp-users mailing list