DHCP client not working

Kishore Kumar Kakarla Kishore_Kakarla at infosys.com
Wed Jul 6 08:02:44 UTC 2011

DHCPv4 client package has been modified to use sockets by defining USE_SOCKETS in site.h of the includes directory so that it works for ppp interface.

Now when I run dhcp client it is sending DHCP DISCOVER messages, server is responding with a new IP address, which is coming to the m/c (tcpdump report) but DHCP client is not taking the address and assigning to the interface.

On the machine I have multiple interfaces. I am running DHCP client on eth1 interface and when I see the tcpdump request I see it is going as where is IP address of another interface eth0. DHCP server is responding with new IP address.

When I run DHCP client with USE_SOCKETS disabled the request is going as and server is responding, IP is assigned to eth1 interface.

Could someone let me know the reason why the request is going with and is this the reason why DHCP client is not accepting IP address for eth1 interface?

tcpdump on client side:
[cid:image001.png at 01CC3BE1.2966DFF0]

Thanks & regards
Kishore Kumar Kakarla

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/dhcp-users/attachments/20110706/fa800a42/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 19451 bytes
Desc: image001.png
URL: <https://lists.isc.org/pipermail/dhcp-users/attachments/20110706/fa800a42/attachment.png>

More information about the dhcp-users mailing list