IPv6 DDNS with dhcp-4.2.1

Jonathan Barber jonathan.barber at gmail.com
Thu Mar 17 09:45:33 UTC 2011

On 16 March 2011 18:37,  <sub at nryc.fr> wrote:
> Le 16/03/2011 18:56, Jonathan Barber a écrit :
>> I'm trying (and failing) to get dhcpd to update my DNS server with the
>> hostname defined by the name of the host declarations for IPv6
>> clients.


>> Should it work? Can anyone see if I'm missing something obvious?
> Maybe the "ddns-domainname" statement?
> I'm new to DHCP(v6) and DDNS but I think "host" statements are global so you
> have to tell on which DNS zone the DHCP should make the update.
> In my case it's on the global configuration section and also in my "subnet6"
> section. You don't use IPv6 ranges so maybe you need to put it in you "host"
> section.

I tried adding the ddns-domainname parameter in multiple places in my
config, all to no avail.

But I changed the host and subnet6 declarations to:
host ies-dev-gluster3 {
	host-identifier option dhcp6.client-id
	ddns-hostname "foo";

subnet6 fc00::/7 {
	range6 fc00::2 fc00::20;

And it's now registering AAAA record in DNS. Adding the fixed-address6
statement back to the host declaration breaks the DDNS.

Setting "ddns-hostname = host-decl-name;" doesn't work and gives the
error message:
data: host_decl_name: not available

I've also tried the "use-host-decl-names on" statement in a global,
but it doesn't do anything.

I guess these are bugs, so I'll raise them on the bug list.

Thanks for your help.

> Nicolas
Jonathan Barber <jonathan.barber at gmail.com>

More information about the dhcp-users mailing list