dhcp not matching subnet if not first address on interface

Steve Clark sclark at netwolves.com
Tue Sep 6 02:02:14 UTC 2011

On 09/05/2011 09:16 PM, Rick Dicaire wrote:
> On Mon, Sep 5, 2011 at 8:57 PM, Steve Clark<sclark at netwolves.com>  wrote:
>> Running OK.
> Oh wow...have you tried aliasing the second IP to eth2:0, then starting dhcpd?
No Joy - get the same result.
eth2:1    Link encap:Ethernet  HWaddr 00:02:B6:36:D1:39
           inet addr:  Bcast:  Mask:
           UP BROADCAST MULTICAST  MTU:1500  Metric:1

  /usr/sbin/dhcpd -4 eth2:1
Internet Systems Consortium DHCP Server 4.1.1-P1
Copyright 2004-2010 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not specified in the config file
Wrote 0 leases to leases file.

No subnet declaration for eth2:1 (no IPv4 addresses).
** Ignoring requests on eth2:1.  If this is not what
    you want, please write a subnet declaration
    in your dhcpd.conf file for the network segment
    to which interface eth2:1 is attached. **

Not configured to listen on any interfaces!

Stephen Clark
Sr. Software Engineer III
Phone: 813-579-3200
Fax: 813-882-0209
Email: steve.clark at netwolves.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/dhcp-users/attachments/20110905/8d5d98cd/attachment.html>

More information about the dhcp-users mailing list