Macbook Pro/MacOS X 10.6.8 won't accept DHCPOFFER

Chuck Anderson cra at WPI.EDU
Fri Mar 16 16:10:20 UTC 2012

Has anyone experienced a problem where MacOS X 10.6.8 (or other
versions) won't accept the DHCPOFFER from the server?  I'm pretty sure
this isn't affecting ALL Macs on my network, because if it was I would
have many more complaints than just the one system I'm troubleshooting
now.  But this one Mac won't accept DHCPOFFER from either its wired
Ethernet (en0) or wireless Airport (en1) interfaces.  I've tried
everything short of deleting plist files or reinstalling the OS, but
nothing has worked so far.  The firewall is disabled, no Internet
Sharing option is enabled (but it had been), the network configuration
has been deleted and re-created, "Locations" were deleted, all
Software Updates are applied, etc.

I've confirmed that the DHCPOFFERs are getting to the Mac by doing
tcpdump -i en0 (or en1), but the Mac ignores them and doesn't send a
DHCPREQUEST.  There is only one peculiarity about the OFFERS that I
can see.  They do NOT have the broadcast flag set, but they are being
sent to the all-ones broadcast addresses FF:FF:FF:FF:FF:FF / due to how the relay agent is configured.  The relay
agent needs to always broadcast in order to work at all (the
implementation of the relay agent in the router can't lookup/add a
route to the layer 2 destination from the layer 3 interface in order
to unicast the DHCPOFFERs/DHCPACKs to the clients).  This doesn't
cause a problem with any other clients, and like I said, even other
Macs are working.

I'd appreciate any advice/knowledge on how to troubleshoot the DHCP
client in Mac OS.  Searching the Apple support forums, other internet
forums, and mailing list posts (including archives of this list) has
proved fruitless so far.


More information about the dhcp-users mailing list