"raw packet not available" when execute() on release

Glenn Satchell glenn.satchell at uniq.com.au
Tue May 1 00:08:53 UTC 2012

Hi Nicolas

Can you post your dhcpd.conf? It depends when you call execute, if it's 
done during, for example, DHCPDISCOVER, then the packet does not contain 
an IP address yet.

You can test the value of option dhcp-message-type (man dhcp-options). 
You probably only want to do a DNS update during state DHCPACK and 

if option dhcp-message-type = 5 {
   execute ( ..... )


On 05/01/12 06:42, Nicolas C. wrote:
> On 30/04/2012 21:06, Nicolas C. wrote:
>> I'm using the official "isc-dhcp-server" package on Debian Squeeze
>> (4.1.1-P1), maybe this issue is corrected in a newer version of dhcpd? I
>> tried compiling 4.2.3-P2 to test but it fails :
>> comapi.c:878:25: error: variable 'shared_network' set but not used
>> [-Werror=unused-but-set-variable]
>> cc1: all warnings being treated as errors
>> make[2]: *** [comapi.o] Error 1
>> make[2]: Leaving directory `/usr/src/dhcp-4.2.3-P2/common'
>> Any help on the "execute" or compiling issue? This is quite a problem
>> for me.
> Compiling problem solved, I had to delete every occurrence of -Werror in
> Makefiles after "configure" :
> find . -name Makefile | xargs sed -e "s/-Werror //" -i
> DHCPD 4.2.3-P2 is now running, I have to wait & see if my "raw packet
> not available" error is still there.
> Nicolas
> _______________________________________________
> dhcp-users mailing list
> dhcp-users at lists.isc.org
> https://lists.isc.org/mailman/listinfo/dhcp-users

More information about the dhcp-users mailing list