DHCPv6 Client sending ICMP redirect message

Sujata Verma sujataverma3 at yahoo.com
Wed Nov 28 11:23:24 UTC 2012

Sorry, i could solve my problem , it seems that the issue was, even though the messages were getting exchanged, apparantly, the NDP was failing for link local IP address. So when i tried to ping with their link local ip address , it was not even pinging. I assumed that , if they are receiving each other message, they seem to know each other. 

But it was not the case.

Why it was sending redirect message, i am still not sure.

What i did to resolve the issue, it seems stupid to me , but there has to be reason for it, one of many  things which i dont know.

Instead of using command line at client , i used-> GUI-> networking-> Edit connection-> wired connection->IPv6 setting->Selected, automatic, DHCP mode-> checked " required IPv6 addressing for this connection to complete" -> ok

made interface up and down , and everything started working.

So looks like the command to start dhcp client is missing something? Any inputs ?

Thanks for any help or comments.


 From: Sujata Verma <sujataverma3 at yahoo.com>
To: dhcp <dhcp-users at lists.isc.org> 
Sent: Wednesday, November 28, 2012 4:02 PM
Subject: DHCPv6 Client sending ICMP redirect message


This is my setup

Linux Fedora core 16 DHCP Client 4.2.4-P2-----Ethernet---Linux Fedora core 16 DHCP Server 4.2.4-P2

The DHCPv6 client is sending Solicit message, the DHCP server is replying with Advertise message, but the client is not replying with "REPLY" instead it sends ICMPv6 rediret message to server, and server responds with ICMP destination unreachable message. After this process the client again sends the Solicit message,and the process gets repeated, the client doesnt get the ip address.

The same ISC DHCP server if i connect with Windows 2008 as DHCP client, it is accepting the ip address and is working fine.

Below is config file for server with subnet declaration, other are default value from sample file:


subnet6 2001:db8:1:0::/64 {
        range6 2001:db8:1:0::7:8 2001:db8:1:0::7:254;

        range6 2001:db8:1:0:: temporary;

        prefix6 2001:db8:1:0:: 2001:db8:1:0:: /64;

       option dhcp6.name-servers 2001:db8:1::9:9, 2001:db8:1::9:8;



starting the server with:

dhcpd -6 -d -cf /etc/dhcp/dhcpd6.conf

The client file is at /etc/dhcp/dhclient6.conf, created manually with following option:


script "/sbin/dhclient-script";

interface "em1" {

                 request dhcp6.name-servers;


the "em1" is the Ethernet interface present on client.

the client is started by using following command:

/sbin/dhclient -d -6 -sf /sbin/dhclient-script  -cf /etc/dhcp/dhclient6.conf 

The iptables, ip6tables and SELinux are disabled on both the machine.

The wireshark capture for the message exchange are attached for reference, please let me know, what could be the issue ?

thanks for any comments or  help.


dhcp-users mailing list
dhcp-users at lists.isc.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/dhcp-users/attachments/20121128/7854f599/attachment.html>

More information about the dhcp-users mailing list