Isc dhcp server v6 configuration for clients through a relay

Michal Kostěnec kostenec at
Sat Sep 14 11:50:58 UTC 2013

Hi Joseph,
this situation is the same as IPv4 relaying. You have to configure empty declaration for least one of directly connected subnets (condition accomplished) and all other relayed subnets.
For example:

subnet6 2013:0:0:1::/64 {

subnet6 2013:dead:beef:8001::/64 {
	range6 range6 2013:dead:beef:8001::1001 2013:dead:beef:8001::1999;


On 14. 9. 2013, at 13:21, joseph orfeuil <joseph.orfeuil at> wrote:

> Hello,
> i'm running isc-dhcp-server 4.1-ESV-R4 on ubuntu 12.04.
> The NIC dhcpd is bound to is an ipv6 interface (actually dual stack but only configured for IPv6).
> My DHCP server is in network A and my point would be to serve IP addresses to network B.
> There's a router between networks A and B, acting as a dhcp relay.
> Example :
> Network A ==== Router ==== Network B
> Let's assume Network A subnet is 2013:0:0:1::/64 and Network B subnet is 2013:dead:beef:8001::/64
> Let's also consider DHCP server address is 2013:0:0:1::bbbb/64.
> My point would then be to allocate addresses belonging to prefix 2013:dead:beef:8001.
> Below is an example of my dhcpd6.conf (at least the way i'd like to see it working).
> default-lease-time 600;
> max-lease-time 7200;
> log-facility local7;
> option dhcp6.rapid-commit;
> pid-file-name "/var/run/dhcp-server/";
> subnet6 2013:0:0:1::/64 {
> 	range6 2013:dead:beef:8001::1001 2013:dead:beef:8001::1999;
> 	prefix6 2013:0:0:100:: 2013:0:0:f00:: /56;
> }
> When running like this, when receiving a sollict request, no reply is sent (using rapid commit that's why next step is reply) because it says "No subnet found for link-address 2013:dead:beef:8001::"
> range6 2013:0:0:1::1001 2013:0:0:1::1999; works... but then, i have clients in network B receiving IPs from network A... which does not work.
> If ever i configure an additional address 2013:dead:beef:8001::bbbb/64 on DHCP server side, i'm then stuck as i won't be able to indicate that 2013:dead:beef:8001::/64 has to be reached through the router (actually tried).
> On the other hand, i also tried to configure the DHCP server with a subnet6 2013:dead:beef:8001::/64{}, thinking this is the actual subnet in DHCP sollicit before it is relayed... but then the server just won't start as there's no subnet6 declaration matching the one configured on the machine interface.
> Any help would be very much appreciated. I don't really understand why addresses i'm attempting to allocated are verified as to be part of network A. Is there any configuration i miss to indicate we are serving for client behind a relay?
> Thanks a lot.
> Regards
> Joseph
> _______________________________________________
> dhcp-users mailing list
> dhcp-users at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the dhcp-users mailing list