dhcpd + ldap + TLS crash

Mark Pavlichuk pav5088 at internode.on.net
Sun Feb 16 16:22:35 UTC 2014

I have a working OpenLDAP directory supporting several services, and am attempting to connect dhcpd.  My OpenLDAP config is perhaps slightly unusual in that the server demands certs from clients.  dhcpd is crashing, and after much troubleshooting I'm out of ideas so I'm posting here.  A list of debugging steps, valgrind output, configuration etc... is here:https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=723773  .  I'm using the isc-dhcp-server-ldap package from Debian... and I've tried both versions 4.2.2 and 4.2.4.  Any ideas on what else I could try would be much appreciated.

BTW, GnuTLS specific config options which have worked for me in the past seemed to stop eg.:
ldap-tls-crlfile "/etc/ssl/crl/ssl-cert-local-ca.crl";
...gave an error until I changed to openssl-friendly config.
This may also be due to recent packaging change/s involving adding openssl support, or the fact I'd previously connected to OpenLDAP using ldaps:// and not start_tls.

Mark Pavlichuk

More information about the dhcp-users mailing list