Spontaneously shortened leases

Patrick Trapp ptrapp at nex-tech.com
Fri Jan 9 21:38:28 UTC 2015

We are running a pair of 4.2.7 servers in failover mode. On Christmas, we had an issue with the
clients on the network they support and eventually discovered that the servers were handing out leases with 60-second lease times. As a result, the servers were swamped with DHCP requests and the clients were unable to consistently get and keep an address as the servers were dropping tens of thousands of packets a second as every device tried to renew.

It was noted that the normal "balancing" entries (for failover) in the dhcp logs were not present during this time.

The timestamps on the configuration files where the leases are configured were several months old and were still correctly configured for 24-hour leases.

We tried stopping DHCP on each of the servers for a time to see if the remaining server would take over without success. Ultimately, we had to restart one of the servers itself, not just its DHCP process, to recover.

Once that was done and the downed server came online, the balancing entries were visible in the logs once again and the leases were for 24 hours instead of 60 seconds. Has anyone else seen this problem? We have had no success determining what started this and would prefer to avoid it in the future as it took ten days to get all of clients straightened back out.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/dhcp-users/attachments/20150109/3a7a3ea6/attachment.html>

More information about the dhcp-users mailing list