PD broken in v4.3.2? prefix6 start prefix is outside the subnet

Chris Buechler cmb at pfsense.org
Tue Jul 14 21:34:23 UTC 2015

DHCPv6 PD configurations that worked in 4.3.1, 4.2.x, and earlier
versions have stopped working in 4.3.2. For instance, this
configuration will no longer work.

every instance of 'prefix6' I found in this list's archives will no
longer work, examples all over the Internet like this no longer work.

You end up getting "prefix6 start prefix is outside the subnet".

That's a result of this change noted in the release notes:

- Added checks in range6 and prefix6 statement parsing to ensure addresses
  are within the declared subnet. Thanks to Jiri Popelka at Red Hat for the
  bug report and patch.
  [ISC-Bugs #32453]
  [ISC-Bugs #17766]
  [ISC-Bugs #18510]
  [ISC-Bugs #23698]
  [ISC-Bugs #28883]

range6 I can understand. prefix6 seems to be a mistake though. Of
course it's outside the subnet, that's the nature of PD. There has
never been a requirement previously for prefix6 to be within the
declared subnet, and it worked fine. Now I can't find a conf file
anywhere that actually works with PD, across a variety of
circumstances that worked on 4.3.1 and earlier.

Is there something I'm missing here, or is PD actually broken?


More information about the dhcp-users mailing list