DHCPv6 isn't updating DNS

Joshua Schaeffer jschaeffer0922 at gmail.com
Sun Jul 30 23:00:42 UTC 2017

On 07/30/2017 06:53 AM, Bill Shirley wrote:
> I'm a bit confused because you appear to have two named.conf files, one for
> IPv4 and one for IPv6.  I only have one DNS server which handles both IPv4
> and IPv6.  My DHCP and DNS services run on the same machine.  I have:
> key DHCP_UPDATER                { algorithm hmac-md5;    secret <the_secret>; };
> zone lan.example.com.            { primary;    key DHCP_UPDATER; }
> Note the for both IPv4 and IPv6.

Yes, I do have two config files, but only for comparison/testing purposes. I actually only need DHCPv6, but because I couldn't get it to work, I wanted to see if I could get it to work with IPv4 (which I can). So when I use the IPv4 config file, I run dhcpd with -4 and when I run the IPv6 config file I run dhcpd with -6. So when you say you have both IPv4 and 6 running on the same server, do you mean two instances of dhcpd on the same server? It was my understanding that you can't run the same instance of dhcpd for both IPv4 and 6. The man page seems to indicate this:

    -4     Run as a DHCP server. This is the default and cannot be combined with -6.
    -6     Run as a DHCPv6 server. This cannot be combined with -4.

> I did have to set (in both dhcpd.conf):
> update-conflict-detection    off;
> to enable both DHCPs to update the DNS.

I'll give this option a try, thanks.

Joshua Schaeffer
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/dhcp-users/attachments/20170730/bb89eaab/attachment.html>

More information about the dhcp-users mailing list