dhcpd-4.3.6 works only when launched with -f or -d flag

m.madej at xtrack.pl m.madej at xtrack.pl
Fri Mar 1 06:10:28 UTC 2019


I try to run dhcpd on my wifi network. I build it using Yocto and here 
are a versions of my built system:

kernel: 4.14

dhcpd: 4.3.6

bind: 9.10.6-r0

everything is running on cortex a5 core (sama5d27 processor)

When i run dhcpd manually with -d or -f option (debug or foreground) 
everything seems to work fine. But when dhcpd is started as daemon it 
does not work at all.

I run strace and it seems it hangs on: "futex(0xb6913098, 

I found a bug with similar behaviour here 
https://bugs.launchpad.net/ubuntu/+source/isc-dhcp/+bug/1551855 but as i 
understand it should be fixed in version i use.

Does someone have any idea?

Thanks in advance

Mariusz Madej
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/dhcp-users/attachments/20190301/7f5b418a/attachment-0001.html>

More information about the dhcp-users mailing list