<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">

<head>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii">
<meta name=Generator content="Microsoft Word 12 (filtered medium)">
<style>
<!--
 /* Font Definitions */
 @font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;}
@page Section1
        {size:612.0pt 792.0pt;
        margin:72.0pt 90.0pt 72.0pt 90.0pt;}
div.Section1
        {page:Section1;}
-->
</style>
<!--[if gte mso 9]><xml>
 <o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
 <o:shapelayout v:ext="edit">
  <o:idmap v:ext="edit" data="1" />
 </o:shapelayout></xml><![endif]-->
</head>

<body lang=FR-CA link=blue vlink=purple>

<div class=Section1>

<p class=MsoNormal><span lang=EN-US>Hi,<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US>I have a problem today and I really don’t
understand why. <o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US>I’m running 4.1.0 in failover mode
(also tried 4.1.1b3). My lease time in dhcpd.conf is 86400 and everytime I
release/renew my ip from windows xp, I get a lease of 3600. I used
tcpdump/wireshark to see what’s going on and everything is fine except
the lease:<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US>    Option: (t=51,l=4) IP Address Lease
Time = 1 hour<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        Option: (51) IP Address Lease Time<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        Length: 4<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        Value: 00000E10<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US>The only value of 3600 that I have in my
config is for mclt (Max Client Lead Time) and max-balance in the failover
section. If I change the mclt value to, let say, 14400, than I get a lease time
of 14400. When I return it to 3600, I get 3600… Some network are ok and
receive the 86400 lease time… The subnet declarations are identical.<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US>If I create a static host entry in my
config for that pc, I get the 86400 lease time. But as soon as I comment the
static entry I return to 3600 lease time.<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US>I also noticed that when the servers are
restarting after a config change, sometime, if I release/renew at the same time
of the server restart, I get 86400. If I renew after that I return to 3600…<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US>I don’t remember, but I don’t
think I had this problem last week (Friday). Something to do with daylight saving
time change this weekend?<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US>Can someone help me with this???<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US>Dhcpd.conf:<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>…<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>default-lease-time 86400;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>max-lease-time 86400;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>…<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>#On master:<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>failover peer "failover-u" {<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        primary;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        address 192.168.10.10;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        port 519;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        peer address 192.168.10.11;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        peer port 520;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        max-response-delay 180;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        max-unacked-updates 10;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        load balance max seconds 5;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        mclt 3600;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        split 128;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        min-balance 300;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        max-balance 3600;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>}<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US>#On secondary<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>failover peer "failover-u" {<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        secondary;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        address 192.168.10.11;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        port 520;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        peer address 192.168.10.10;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        peer port 519;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        max-response-delay 180;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        max-unacked-updates 10;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        load balance max seconds 5;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        min-balance 300;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        max-balance 3600;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>}<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>…<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>subnet 10.35.32.0 netmask 255.255.255.0 {<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        option subnet-mask 255.255.255.0;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        option broadcast-address
10.35.32.255;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        option routers 10.35.32.1;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        pool {<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>                failover peer
"failover-u";<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>                deny dynamic bootp clients;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>                range 10.35.32.128
10.35.32.223;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>                allow all clients;<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>        }<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>}<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p>

<p class=MsoNormal><span lang=EN-US>Thanks,<o:p></o:p></span></p>

<p class=MsoNormal><span lang=EN-US>Denis Laventure<o:p></o:p></span></p>

</div>

</body>

</html>