This is a misbehavior of the DHCP client, as it doesn't look at the changed options during<div>a renew of its lease.</div><div><br></div><div>This has been observed with many dhcp clients, even the isc one.</div><div><br>
</div><div><br><br><div class="gmail_quote">On 13 April 2012 23:25, Teva AVRIL-TEIPOARII <span dir="ltr"><<a href="mailto:teva@viti.pf">teva@viti.pf</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
Greetings,<br>
<br>
I've got a dhcpd server, which is working good. However i've got an issue:<br>
i've modified one parameter on the dhcpd.conf for one subnet (i've changed<br>
option domain-name-servers ip), i've restarted the dhcpd service.<br>
<br>
My issue is i've got an ip address, but not the update DNS-servers.<br>
<br>
Here below configuration of the dhcpd.conf before modification:<br>
<br>
shared-network test {<br>
option domain-name "<a href="http://test.com" target="_blank">test.com</a>";<br>
option domain-name-servers 192.168.1.2, 192.168.1.3;<br>
default-lease-time 360;<br>
max-lease-time 360;<br>
<br>
subnet 192.168.10.0 netmask 255.255.255.0 {<br>
option routers 192.168.10.254;<br>
option subnet-mask 255.255.255.0;<br>
option broadcast-address 192.168.10.255;<br>
}<br>
<br>
pool {<br>
range 192.168.10.1 192.168.10.253;<br>
}<br>
}<br>
<br>
And now after modification:<br>
<br>
shared-network test {<br>
option domain-name "<a href="http://test.com" target="_blank">test.com</a>";<br>
option domain-name-servers 192.168.45.1, 192.168.1.3;<br>
default-lease-time 360;<br>
max-lease-time 360;<br>
<br>
subnet 192.168.10.0 netmask 255.255.255.0 {<br>
option routers 192.168.10.254;<br>
option subnet-mask 255.255.255.0;<br>
option broadcast-address 192.168.10.255;<br>
}<br>
<br>
pool {<br>
range 192.168.10.1 192.168.10.253;<br>
}<br>
}<br>
<br>
And here below global parameters applied to all subnets:<br>
<br>
<br>
ddns-update-style none;<br>
authoritative;<br>
log-facility local7;<br>
update-static-leases on;<br>
<br>
<br>
<br>
<br>
The result is that instead of having 192.168.45.1 and 192.168.1.3 as primary<br>
and secondary DNS, i still got 192.168.1.2 and 192.168.1.3 as primary and<br>
secondary DNS.<br>
<br>
I've deleted dhcpd.leases , thinking that maybe the issue could come from<br>
some leases not expired, but result is the same.<br>
<br>
I've performed a wireshark capture, and during the DORA process, i see that<br>
the DHCP server is sending the update DNS as it should. However on my PC (on<br>
Windows), i still see old DNS servers attributed (attribution is automatic,<br>
it's not in static on network configuration of the PC).<br>
<br>
I don't understand where this problem come from, if you have an idea, please<br>
let me know.<br>
<br>
<br>
<br>
_______________________________________________<br>
dhcp-users mailing list<br>
<a href="mailto:dhcp-users@lists.isc.org">dhcp-users@lists.isc.org</a><br>
<a href="https://lists.isc.org/mailman/listinfo/dhcp-users" target="_blank">https://lists.isc.org/mailman/listinfo/dhcp-users</a><br>
</blockquote></div><br><br clear="all"><div><br></div>
</div>