ISC DHCP does not work with BIND 9.10

Jiri Popelka jpopelka at
Thu Feb 19 18:20:29 UTC 2015

On 02/19/2015 06:40 PM, 神明達哉 wrote:
> At Thu, 19 Feb 2015 18:17:13 +0100,
> Tomas Hozza <thozza at> wrote:
>> We have been linking DHCP against separately built BIND in the past and everything
>> worked for years. Only thing that changed is that we updated latest BIND
>> 9.9 to latest 9.10.
> Ah, I realized I was probably not clear enough about one important
> point: The two points that make this combination of DHCP and BIND9
> unworkable is new in BIND 9.10.  Up to 9.9 there's a separately built
> library named "export library", which I guess you have been using.
> BIND 9.10 now builds a single unified library which is seemingly
> supposed to work both for BIND 9's internal applications and for other
> general applications (one possibility of which would be DHCP).  But
> the "unified" library that would be used for BIND 9 has the two
> problems I mentioned and won't work for DHCP.
> If you don't mind still building a separate (set of) library, I
> believe you can use this workaround:
> - Build (libraries of) BIND 9 with --disable-epoll and --disable-threads

Thank you !

Building BIND 9 with --disable-epoll && --disable-threads
make dhclient/dhcpd work when running in background.

But it's still not possible to stop them, one has to use 'kill -9'.
Any ideas ?


More information about the dhcp-workers mailing list