Compile problems because config.h.in

Russ Allbery rra at stanford.edu
Tue Jan 18 01:39:11 UTC 2000


Heiko Schlichting <inn-bugs at fu-berlin.de> writes:

> PS: the patch should prevent checking for libcrypt and libbsd because it
>     isn't a good idea to use these libraries on IRIX although they exists.
>     Other products, e.g. squid, remove the bsd library from the list in
>     configure if the operating system is IRIX*. I don't know if it is of
>     general interest to expand configure.in of IRIX in a similar way because
>     it breaks the concepts of autoconf a little bit. On the other hand is
>     there already some Solaris depended code in configure.in.

Not sure if I ever responded to this, but just for the record, this
problem should be fixed in INN 2.3.  We now only add libcrypt and libbsd
if they're necessary to pick up the functions we're looking for, and not
if they're in libc.

-- 
Russ Allbery (rra at stanford.edu)         <URL:http://www.eyrie.org/~eagle/>



More information about the inn-bugs mailing list