problem w/ctlinnd using unix domain sockets on SCO unix (w/workaround)

Tom Parker tom at
Mon May 7 02:09:11 UTC 2001

First off I have to tell you that INN is great software that compiled
and installed easily!

I ran into one problem.  Any command with ctlinnd gave a response of
"(sendto failure) Destination address not specified."  Everything else
worked fine.  I traced it down via some old v1.7 FAQ's to a unix domain
socket problem but couldn't figure out where a permissions problem was
if there was one.  I wound up commenting out HAVE_UNIX_DOMAIN_SOCKETS in
include/config.h and everything has been working perfectly since.

My configure options are:

My environment is:
	Inn v2.3.2
	SCO Unix v5.0.5
	SCO Unix development libraries v5.1.1A
	gcc version

"A computer lets you make more mistakes faster than any invention in
 human history--with the possible exceptions of handguns and tequila."
   - Mitch Ratcliffe, _Technology Review_, April, 1992
Tom Parker, tom at OR tomp1 at

More information about the inn-bugs mailing list