INN commit: trunk/doc/pod (install.pod)

INN Commit rra at isc.org
Wed May 11 06:45:16 UTC 2011


    Date: Tuesday, May 10, 2011 @ 23:45:16
  Author: eagle
Revision: 9200

Fix broken or obsolete links in install documentation

Update the link for installing Perl to the result of the current
permanent redirect.  Remove the paragraph about installing the
commercial version of PGP, since www.pgp.com now redirects to the
Symantec product page, which makes no mention of the PGP that would
be of interest to an INN installer.

Modified:
  trunk/doc/pod/install.pod

-------------+
 install.pod |   30 +++++++++++-------------------
 1 file changed, 11 insertions(+), 19 deletions(-)

Modified: install.pod
===================================================================
--- install.pod	2011-04-16 10:22:18 UTC (rev 9199)
+++ install.pod	2011-05-11 06:45:16 UTC (rev 9200)
@@ -88,16 +88,15 @@
 =item *
 
 INN requires at least S<B<Perl 5.8.0>> to build and to run several
-subsystems.  In order to process control messages, B<controlchan> needs
-the C<MIME::Parser> module available from CPAN (C<MIME-tools>
-in F<modules/by-module/MIME/>, for instance on L<ftp://ftp.perl.org/>).  This
+subsystems.  In order to process control messages, B<controlchan>
+needs the C<MIME::Parser> module available from CPAN (C<MIME-tools> in
+F<modules/by-module/MIME/>, for instance on L<ftp://ftp.perl.org/>).  This
 Perl module has probably already been packaged for your distribution.
-INN is tested primarily with newer versions of Perl, so it's
-generally recommended that you install the latest stable distribution of
-Perl before compiling INN.  For instructions on obtaining and installing
-Perl, see L<http://www.perl.com/pub/language/info/software.html>.  Note
-that you may need to use the same compiler and options (particularly
-large file support) for Perl and INN.
+INN is tested primarily with newer versions of Perl, so it's generally
+recommended that you install the latest stable distribution of Perl before
+compiling INN.  For instructions on obtaining and installing Perl, see
+L<http://www.perl.org/get.html>.  Note that you may need to use the same
+compiler and options (particularly large file support) for Perl and INN.
 
 If you're using a version of Perl prior to 5.6.0, you may need to make
 sure that the Perl versions of your system header files have been
@@ -128,17 +127,10 @@
 hierarchies) then you will need to install some version of PGP.  The
 recommended version is B<GnuPG>, since it's actively developed, supports
 OpenPGP, is freely available from L<http://www.gnupg.org/> and free to use
-for any purpose (in the US and elsewhere), and (as of version 1.0.4 at least)
-supports the RSA signatures used by most current control message senders.
+for any purpose (in the US and elsewhere), and (as of version 1.0.4 at
+least) supports the RSA signatures used by most current control message
+senders.
 
-Alternately, you can install PGP from L<http://www.pgp.com/> or one of the
-international versions of it.  Be warned, however, that the licensing
-restrictions on PGP inside the United States are extremely unclear; it's
-possible that if you are installing INN for a company in the U.S., even if
-the news server is not part of the business of that company, you would
-need to purchase a commercial license for PGP.  For an educational or
-non-profit organization, this shouldn't be a problem.
-
 =item *
 
 If you want to use either the Python embedded hooks, you'll need to have a




More information about the inn-committers mailing list