INN commit: branches/2.5 (configure.ac)

INN Commit rra at isc.org
Sat May 2 15:39:27 UTC 2015


    Date: Saturday, May 2, 2015 @ 08:39:27
  Author: iulius
Revision: 9840

configure.ac:  Build fix for current Mac OS X versions

The build was failing with recent versions of Mac OS X:

  clang: error: no such file or directory: '/usr/local/news/lib/libinn.3.dylib'
  make[1]: *** [libinn.la] Error 1
  make: *** [all-lib] Error 2

The reason is the '-multiply_defined'-part of the command line. 
This switch is marked as obsolete in ld(1):     

  -multiply_defined treatment
        Previously provided a way to warn or error if any of the sym-
        bols used from a dynamic library were also available in
        another linked dynamic library.  This option is obsolete.

Thanks to Dennis Preiser for the report.

Modified:
  branches/2.5/configure.ac

--------------+
 configure.ac |    5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Modified: configure.ac
===================================================================
--- configure.ac	2015-05-02 15:38:55 UTC (rev 9839)
+++ configure.ac	2015-05-02 15:39:27 UTC (rev 9840)
@@ -238,8 +238,9 @@
     fi
     ;;
 
-dnl OSX needs -multiply_defined suppress.
-*darwin*)
+dnl Mac OS X needed "-multiply_defined suppress" before this linker flag became
+dnl obsolete (darwin13 is Mavericks, OS X v10.9).
+*-darwin[[0-9]].*|*-darwin1[[0-2]].*)
     LDFLAGS="$LDFLAGS -multiply_defined suppress"
     ;;
 



More information about the inn-committers mailing list