INN commit: branches/2.6 (7 files)

INN Commit rra at isc.org
Wed Jan 20 12:02:48 UTC 2021


    Date: Wednesday, January 20, 2021 @ 04:02:47
  Author: iulius
Revision: 10533

Update to latest upstream files

control.ctl, pgpverify, Libtool, pkg-config, config.guess and config.sub

Modified:
  branches/2.6/control/pgpverify.in
  branches/2.6/m4/libtool.m4
  branches/2.6/m4/pkg.m4
  branches/2.6/samples/control.ctl
  branches/2.6/support/config.guess
  branches/2.6/support/config.sub
  branches/2.6/support/ltmain.sh

----------------------+
 control/pgpverify.in |    2 +-
 m4/libtool.m4        |    4 ++--
 m4/pkg.m4            |    4 ++--
 samples/control.ctl  |    7 ++++---
 support/config.guess |   39 +++++++++++++++++++++++++++------------
 support/config.sub   |   14 ++++++++------
 support/ltmain.sh    |    4 ++--
 7 files changed, 46 insertions(+), 28 deletions(-)

Modified: control/pgpverify.in
===================================================================
--- control/pgpverify.in	2021-01-20 12:00:42 UTC (rev 10532)
+++ control/pgpverify.in	2021-01-20 12:02:47 UTC (rev 10533)
@@ -21,7 +21,7 @@
 #    GnuPG 1.x before 1.4.20, and GnuPG 2.0.x) still validates signatures
 #    made with weak digest algorithms like MD5 whereas current versions
 #    of gpgv no longer do.
-#    This new release of pgpverify requires at least GnuPG 1.4.20 or 2.1.0.
+# -- This new release of pgpverify requires at least GnuPG 1.4.20 or 2.1.0.
 #    If you're using an older version of GnuPG, you have to keep using
 #    pgpverify 1.29.
 #

Modified: m4/libtool.m4
===================================================================
--- m4/libtool.m4	2021-01-20 12:00:42 UTC (rev 10532)
+++ m4/libtool.m4	2021-01-20 12:02:47 UTC (rev 10533)
@@ -1071,11 +1071,11 @@
       # to the OS version, if on x86, and 10.4, the deployment
       # target defaults to 10.4. Don't you love it?
       case ${MACOSX_DEPLOYMENT_TARGET-10.0},$host in
-	10.0,*86*-darwin8*|10.0,*-darwin[[91]]*)
+	10.0,*86*-darwin8*|10.0,*-darwin[[912]]*)
 	  _lt_dar_allow_undefined='$wl-undefined ${wl}dynamic_lookup' ;;
 	10.[[012]][[,.]]*)
 	  _lt_dar_allow_undefined='$wl-flat_namespace $wl-undefined ${wl}suppress' ;;
-	10.*)
+	10.*|11.*)
 	  _lt_dar_allow_undefined='$wl-undefined ${wl}dynamic_lookup' ;;
       esac
     ;;

Modified: m4/pkg.m4
===================================================================
--- m4/pkg.m4	2021-01-20 12:00:42 UTC (rev 10532)
+++ m4/pkg.m4	2021-01-20 12:02:47 UTC (rev 10533)
@@ -1,4 +1,4 @@
-# pkg.m4 - Macros to locate and utilise pkg-config.   -*- Autoconf -*-
+# pkg.m4 - Macros to locate and use pkg-config.   -*- Autoconf -*-
 # serial 12 (pkg-config-0.29.2)
 
 dnl Copyright © 2004 Scott James Remnant <scott at netsplit.com>.
@@ -86,7 +86,7 @@
 dnl PKG_CHECK_MODULES(), but does not set variables or print errors.
 dnl
 dnl Please remember that m4 expands AC_REQUIRE([PKG_PROG_PKG_CONFIG])
-dnl only at the first occurence in configure.ac, so if the first place
+dnl only at the first occurrence in configure.ac, so if the first place
 dnl it's called might be skipped (such as if it is within an "if", you
 dnl have to call PKG_CHECK_EXISTS manually
 AC_DEFUN([PKG_CHECK_EXISTS],

Modified: samples/control.ctl
===================================================================
--- samples/control.ctl	2021-01-20 12:00:42 UTC (rev 10532)
+++ samples/control.ctl	2021-01-20 12:02:47 UTC (rev 10533)
@@ -1,5 +1,5 @@
 ##  control.ctl - Access control for control messages.
-##  Last modified: 2020-05-03
+##  Last modified: 2020-12-24
 ##
 ##  Based on rone's unified control.ctl file.
 ##
@@ -962,9 +962,10 @@
 rmgroup:news at flora.ottawa.on.ca:flora.*:verify-flora-news
 
 ## FR (French language)
-# URL: http://www.usenet-fr.net/
+# URL: https://www.usenet-fr.net/
 # Admin group: fr.usenet.forums.annonces
-# Key URL: http://www.usenet-fr.net/fur/usenet/presentation-fr.html
+# Key URL: https://www.usenet-fr.net/pgp-fr-2020.txt
+# Key fingerprint: D5F3 69B2 9757 3622 0153  54E7 FA42 3E89 970E B10B
 # *PGP*   See comment at top of file.
 newgroup:*:fr.*:drop
 rmgroup:*:fr.*:drop

Modified: support/config.guess
===================================================================
--- support/config.guess	2021-01-20 12:00:42 UTC (rev 10532)
+++ support/config.guess	2021-01-20 12:02:47 UTC (rev 10533)
@@ -1,8 +1,8 @@
 #! /bin/sh
 # Attempt to guess a canonical system name.
-#   Copyright 1992-2020 Free Software Foundation, Inc.
+#   Copyright 1992-2021 Free Software Foundation, Inc.
 
-timestamp='2020-11-07'
+timestamp='2021-01-01'
 
 # This file is free software; you can redistribute it and/or modify it
 # under the terms of the GNU General Public License as published by
@@ -27,7 +27,7 @@
 # Originally written by Per Bothner; maintained since 2000 by Ben Elliston.
 #
 # You can get the latest version of this script from:
-# https://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess
+# https://git.savannah.gnu.org/cgit/config.git/plain/config.guess
 #
 # Please send patches to <config-patches at gnu.org>.
 
@@ -50,7 +50,7 @@
 GNU config.guess ($timestamp)
 
 Originally written by Per Bothner.
-Copyright 1992-2020 Free Software Foundation, Inc.
+Copyright 1992-2021 Free Software Foundation, Inc.
 
 This is free software; see the source for copying conditions.  There is NO
 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
@@ -138,9 +138,7 @@
 
 case "$UNAME_SYSTEM" in
 Linux|GNU|GNU/*)
-	# If the system lacks a compiler, then just pick glibc.
-	# We could probably try harder.
-	LIBC=gnu
+	LIBC=unknown
 
 	set_cc_for_build
 	cat <<-EOF > "$dummy.c"
@@ -149,16 +147,30 @@
 	LIBC=uclibc
 	#elif defined(__dietlibc__)
 	LIBC=dietlibc
+	#elif defined(__GLIBC__)
+	LIBC=gnu
 	#else
 	#include <stdarg.h>
+	/* First heuristic to detect musl libc.  */
 	#ifdef __DEFINED_va_list
 	LIBC=musl
-	#else
-	LIBC=gnu
 	#endif
 	#endif
 	EOF
 	eval "$($CC_FOR_BUILD -E "$dummy.c" 2>/dev/null | grep '^LIBC' | sed 's, ,,g')"
+
+	# Second heuristic to detect musl libc.
+	if [ "$LIBC" = unknown ] &&
+	   command -v ldd >/dev/null &&
+	   ldd --version 2>&1 | grep -q ^musl; then
+		LIBC=musl
+	fi
+
+	# If the system lacks a compiler, then just pick glibc.
+	# We could probably try harder.
+	if [ "$LIBC" = unknown ]; then
+		LIBC=gnu
+	fi
 	;;
 esac
 
@@ -984,6 +996,9 @@
     k1om:Linux:*:*)
 	echo "$UNAME_MACHINE"-unknown-linux-"$LIBC"
 	exit ;;
+    loongarch32:Linux:*:* | loongarch64:Linux:*:* | loongarchx32:Linux:*:*)
+	echo "$UNAME_MACHINE"-unknown-linux-"$LIBC"
+	exit ;;
     m32r*:Linux:*:*)
 	echo "$UNAME_MACHINE"-unknown-linux-"$LIBC"
 	exit ;;
@@ -1072,7 +1087,7 @@
     ppcle:Linux:*:*)
 	echo powerpcle-unknown-linux-"$LIBC"
 	exit ;;
-    riscv32:Linux:*:* | riscv64:Linux:*:*)
+    riscv32:Linux:*:* | riscv32be:Linux:*:* | riscv64:Linux:*:* | riscv64be:Linux:*:*)
 	echo "$UNAME_MACHINE"-unknown-linux-"$LIBC"
 	exit ;;
     s390:Linux:*:* | s390x:Linux:*:*)
@@ -1638,9 +1653,9 @@
 operating system you are using. If your script is old, overwrite *all*
 copies of config.guess and config.sub with the latest versions from:
 
-  https://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess
+  https://git.savannah.gnu.org/cgit/config.git/plain/config.guess
 and
-  https://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub
+  https://git.savannah.gnu.org/cgit/config.git/plain/config.sub
 EOF
 
 year=$(echo $timestamp | sed 's,-.*,,')

Modified: support/config.sub
===================================================================
--- support/config.sub	2021-01-20 12:00:42 UTC (rev 10532)
+++ support/config.sub	2021-01-20 12:02:47 UTC (rev 10533)
@@ -1,8 +1,8 @@
 #! /bin/sh
 # Configuration validation subroutine script.
-#   Copyright 1992-2020 Free Software Foundation, Inc.
+#   Copyright 1992-2021 Free Software Foundation, Inc.
 
-timestamp='2020-11-07'
+timestamp='2021-01-07'
 
 # This file is free software; you can redistribute it and/or modify it
 # under the terms of the GNU General Public License as published by
@@ -33,7 +33,7 @@
 # Otherwise, we print the canonical config type on stdout and succeed.
 
 # You can get the latest version of this script from:
-# https://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub
+# https://git.savannah.gnu.org/cgit/config.git/plain/config.sub
 
 # This file is supposed to be the same for all GNU packages
 # and recognize all the CPU types, system types and aliases
@@ -67,7 +67,7 @@
 version="\
 GNU config.sub ($timestamp)
 
-Copyright 1992-2020 Free Software Foundation, Inc.
+Copyright 1992-2021 Free Software Foundation, Inc.
 
 This is free software; see the source for copying conditions.  There is NO
 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
@@ -1185,6 +1185,7 @@
 			| k1om \
 			| le32 | le64 \
 			| lm32 \
+			| loongarch32 | loongarch64 | loongarchx32 \
 			| m32c | m32r | m32rle \
 			| m5200 | m68000 | m680[012346]0 | m68360 | m683?2 | m68k \
 			| m6811 | m68hc11 | m6812 | m68hc12 | m68hcs12x \
@@ -1229,7 +1230,7 @@
 			| powerpc | powerpc64 | powerpc64le | powerpcle | powerpcspe \
 			| pru \
 			| pyramid \
-			| riscv | riscv32 | riscv64 \
+			| riscv | riscv32 | riscv32be | riscv64 | riscv64be \
 			| rl78 | romp | rs6000 | rx \
 			| s390 | s390x \
 			| score \
@@ -1241,6 +1242,7 @@
 			| sparcv8 | sparcv9 | sparcv9b | sparcv9v | sv1 | sx* \
 			| spu \
 			| tahoe \
+			| thumbv7* \
 			| tic30 | tic4x | tic54x | tic55x | tic6x | tic80 \
 			| tron \
 			| ubicom32 \
@@ -1685,7 +1687,7 @@
 	musl* | newlib* | uclibc*)
 		;;
 	# Likewise for "kernel-libc"
-	eabi | eabihf | gnueabi | gnueabihf)
+	eabi* | gnueabi*)
 		;;
 	# Now accept the basic system types.
 	# The portable systems comes first.

Modified: support/ltmain.sh
===================================================================
--- support/ltmain.sh	2021-01-20 12:00:42 UTC (rev 10532)
+++ support/ltmain.sh	2021-01-20 12:02:47 UTC (rev 10533)
@@ -39,7 +39,7 @@
 
 PROGRAM=libtool
 PACKAGE=libtool
-VERSION="2.4.6 Debian-2.4.6-14"
+VERSION="2.4.6 Debian-2.4.6-15"
 package_revision=2.4.6
 
 
@@ -2149,7 +2149,7 @@
        compiler:       $LTCC
        compiler flags: $LTCFLAGS
        linker:         $LD (gnu? $with_gnu_ld)
-       version:        $progname $scriptversion Debian-2.4.6-14
+       version:        $progname $scriptversion Debian-2.4.6-15
        automake:       `($AUTOMAKE --version) 2>/dev/null |$SED 1q`
        autoconf:       `($AUTOCONF --version) 2>/dev/null |$SED 1q`
 



More information about the inn-committers mailing list