quick readers.conf question (skipping auth line?)

Basil Kruglov basil at cifnet.com
Tue Nov 9 04:59:05 UTC 1999


Hello everyone,

i upgraded inn recenly (to latest cvsuped version of it)
and now seems like everyone can access my reader box, auth /w ckpasswd is
skipping and letting everyone in.

my ~news/etc/readers.conf looks something like this:

---
auth "default" {
        # default is to allow no access
        #       hosts: "*"
        # uncommenting this will pretend that the remote user is actually named
        # "<no-user>", which will match the "ordinary" access group below by
	<..skipped..>
}

auth "default" {
        # Allow reading/posting from the local host.
        hosts: "stdin,localhost,127.0.0.1"
        default: "*"
        default-domain: "cifnet.com"
}

auth "default" {
        # everyone else
        hosts: "*"
        auth: "ckpasswd -f /usr/local/news/passwd/passwd-db"
}

# ordinary users
access "default" {
        # users can read/post to all but our internal newsgroups.
        users: "*"
        newsgroups: "*,!internal.*"
        access: "Read Post"
}

-------

I didn't make any major changes in readers.conf, all '{}' seems ok, no
errors when i ran inncheck, nothing unusual in news.notice/err,etc either,
ckpasswd is in ~news/bin/auth/passwd, i tried to change auth line
to 'auth: "ckpasswfera-some-crap -f ..."
still open server... skipped authecation, but when i commented out
auth line completely, i got "502 Could not get your access name.  Goodbye."
error.

Anyone? Any help would be much appreciated! :)

-Basil, KOBAN at iRC


More information about the inn-workers mailing list