a problem with expire and history

Toni Maatta toni at mail.teliafi.net
Sun Oct 17 08:23:34 UTC 1999


Hello,

I'm not sure does this message belong here, but I hope I can get some help
to this problem. So I upgraded my INN 1.5.x to 2.2.1. I ran makehistory
with options -r -s <number that wc -l history gave me> and it worked fine,
with no errors or so. Is this the right way to update your history-file
when upgrading? 

After that I have got errors like this:

Duplicate message-id "<7u01kv$2a4$1 at tron.sci.fi>" in history
Duplicate message-id "<7u00lg$adm$1 at wanadoo.fr>" in history
Duplicate message-id "<19991012185716.7760.qmail at master.debian.org>"
in history
Duplicate message-id "<erH24SOF$GA.305 at cpmsnbbsa02>" in history

lot of these errors. So expire doesn't work quite well. It doesn't remove
any messages and my spool is full. So what can I do? Did I do something
wrong or what? I'm using traditional storage method and I compiled my INN
with tagged-hash option (does this option have something to do with
anything)? 

Thanks already. 

- Toni Määttä / toni at teliafi.net





More information about the inn-workers mailing list