ME two filenames for same article

Russ Allbery rra at stanford.edu
Mon Apr 3 04:27:50 UTC 2000


Katsuhiro Kondou <kondou at nec.co.jp> writes:

> I haven't installed 5.6.0 yet, but someone on fj.news.system.inn posted
> the patch for 2.2.2 which he said it worked for him.  Attached.

Cool, thanks.

> --- include/ppport.h.orig	Sun Sep 26 07:42:24 1999
> +++ include/ppport.h	Sun Apr  2 20:11:00 2000
> @@ -145,8 +145,12 @@
>  #	endif
>  #endif
>  #ifndef PERL_PATCHLEVEL
> +#   ifdef PERL_VERSION
> +#	define PERL_PATCHLEVEL PERL_VERSION
> +#   else
>  #	define PERL_PATCHLEVEL PATCHLEVEL
>  #	define PERL_SUBVERSION SUBVERSION
> +#   endif
>  #endif

Yup, that should be equivalent to mine, except that mine switches all uses
to PERL_PATCHLEVEL to PERL_VERSION and basically defines things in the
other direction under the assumption that since PERL_VERSION is what the
Perl headers now use, it's what we should set and use for the tests so
that ppport.h does the minimum work.

If this patch works, I'll also submit it back to the ppport.h maintainer.

-- 
Russ Allbery (rra at stanford.edu)             <http://www.eyrie.org/~eagle/>



More information about the inn-workers mailing list