innd: SERVER cant bind RCreader Permission denied

Jeff Laughlin n1ywb at amsat.org
Tue Jul 25 19:25:57 UTC 2000


Howdy
I beleive I have uncovered an issue with INN 2.2.3, RedHat Linux 6.2, or my
own ignorance.

<begin saga>
The server shipped with RedHat 6.2 and INN 2.2.2. RedHat in all their
cleavernes put the INN files in many different directories, contrary to the
way INN prefers to be installed. Then in light of the 2.2.2 security hole,
I eliminated the original 2.2.2 installation using RPM. I proceded to
download the new 2.2.3 tarball, and install it all according to the
instructions.

rc.news will not execute innd regardless of what uid I execute it as.
innwatch runs and goes to sleep and all, but innd never starts up. Now,
when I run innd by hand as root, everything seems to be fine. The daemon
runs in the background, and everybody's happy. However, if I run innd as
news, I get the following error:
innd: SERVER cant bind RCreader Permission denied
I consulted the FAQ and found the following advice
"Subject: (3.6) syslog message: Can't setup communication (bind failure) 
The message "Can't setup communication (bind failure) Permission denied"
means that the permissions on your _PATH_NEWSCONTROL directory are wrong.
You might want to delete the directory and "make install" to create it again."
This doesn't seem to exactly apply. I have just barely freshly installed
INN. Also, it isn't exactly the error message I'm getting. I also found
"Subject: (3.9) syslog message: ME cant accept RCreader", but that seems
even less applicable. I ALSO found
"Subject: (4.5) My innd won't start!" which says "Izar Tarandach
<izar at cs.huji.ac.il> suggests that another common mistake is that innd
wasn't being started by the correct uid. innd (and therefore rc.news) must
be started from "root" (not "news"). It immediately turns itself in user
"news" once certain tasks are completed." This is contradictory to the
INSTALL file from the tarball which reads
"INN is normally started via the shell script rc.news. This must be run as
  the news user and not as root. Put the following command (or something
  similar) into the system boot script:

        su news -c /usr/local/news/bin/rc.news
"

I apologize for any newbie factor. Clues are appreciated, directions to
support resources I haven't yet found, etc. Thanks.
-73, Jeff

-.  .----  -.--  .--  -...     -.-  ..  -.-.  -.-  ...    .-  ...  ...
Jeffrey Michael Laughlin               	  Amateur Radio Callsign-N1YWB
President, VTC Solar Car Club & Amateur Radio Club W1VTC
Vermont Technical College, Box K155, Randolph Center, VT 05061
(802)728-1481
n1ywb at amsat.org                 http://www.vtc.vsc.edu/users/jlaughli/

Now his life is full of wonder but his heart still knows some fear
Of the simple things he cannot comprehend
Why they try to tear the mountains down and bring in a couple more
More people, more scars upon the land
    -John Denver




More information about the inn-workers mailing list