problems with loops

Rene Imbeau rimbeau at nortelnetworks.com
Tue Jun 20 19:17:45 UTC 2000


Hi,

I would like to know if there is a technique to remove loops in
a bidirectional gateway.

Thanks

René

Rene Imbeau <rimbeau at nortelnetworks.com> writes:

> I set up a mailing list server (majordomo) and a news server (INN).  I

> did the configuration in such way that when I send an email to a
mailing
> list, the email is posted in a corresponding discussion group and when
I
> post an article in a discussion group it is sent the the correspond
> mailing list. Everything seems to work well except that I always
receive
> the following message:

> Subject: mailpost failure (localGroup.test): inews failed: Can't send
> article to the server: 441 Can't set system "X-Trace" header (Article
> not posted.)

You have a loop.  Mail that's been posted is going to the mailing list
and
then being posted back to the newsgroup.  Thankfully, the server is
refusing to post it a second time because X-Trace is present in the
headers (it's added by the news server when the post is made).  I'm
guessing the problem is that you need to make sure that articles can't
loop (the standard problem when doing bidirectional gatewaying).

--
Russ Allbery (rra at stanford.edu)
<http://www.eyrie.org/~eagle/>

--
Rene Imbeau                     Nortel Networks
rimbeau at nortelnetworks.ca       3500 Carling Ave.
Tel: (613) 763-7517             Nepean, Ontario, Canada, K1Y 4H7






More information about the inn-workers mailing list