nntpsend and innxmit

Eilko Bos Eilko.Bos at nl.origin-it.com
Wed Jun 21 09:10:56 UTC 2000

> On Tue, 20 Jun 2000, Eilko Bos wrote:
> > "nntpsend.ctl"
> > serverb:newsfeedb.domain.com:1m:-t60
>   ^^^^^^^
> > news at newsa> /usr/local/news/bin/nntpsend -d
> > nntpsend: [18712:18732] begin newsfeedb.domain.com Tue Jun 20 [...]
>                                 ^^^^^^^^^^^^^^^^^^^^
> Nntpsend SAID above that the sitename is newsfeedb.domain.com, not
> serverb! This script looks for out.going/<site> ==
> out.going/newsfeedb.domain.com in your case. And it tried to process
> non-existent file I think. I suppose your nntpsend.ctl file looks like
> that:
> newsfeedb.domain.com:newsfeedb.domain.com:1m:-t60
> ^^^^^^^^^^^^^^^^^^^^

Hhhhm. Nope. Doesn't work.
I touched the file 'out.going/newsfeedb.domain.com'
I did a posting. The file ''out.going/serverb' was filled with an article-
  number, 'out.going/newsfeedb.domain.com' was empty.
I copied the file 'out.going/serverb' to 'out.going/newsfeedb.domain.com'
I ran /usr/local/news/bin/nntpsend -d
I saw:
	nntpsend: [22588] start
	nntpsend: [22588:22608] begin newsfeedb.domain.com  Wed Jun 21 01:37:40 PDT 2000
	nntpsend: [22588:22608] innxmit -a -d -t60 newsfeedb.domain.com ...
	< 200 newsb.domain.com InterNetNews server INN 2.2.2 13-Dec-1999 ready
	>mode stream
	< 203 StreamOK.
	nntpsend: [22588:22608] end newsfeedb.domain.com Wed Jun 21 01:37:42 PDT 2000
	nntpsend: [22588] stop
/var/spool/news/out.going> ls -lsa
total 6
   2 drwxrwxr-x   2 news     news         512 Jun 21 01:37 ./
   2 drwxr-xr-x  47 news     news        1024 Oct 30  1998 ../
   2 -rw-rw-r--   1 news     news          56 Jun 21 01:37 newsfeedb.domain.com
   0 -rw-rw-r--   1 news     news           0 Jun 21 01:37 serverb

So it DOES use the file 'serverb' (before the exercise the file was empty,
during the exercise it was filled, and after the exercise it wa empty), the
'newsfeedb.domain.com' remains untouched. IMO 'serverb' is a tag which is
needed in both 'nntpsend.ctl' and 'newsfeeds'. The second field in 'newsfeeds'
is the 'exclude' (what serverb puts in its articlespath) and the 2nd field in
nntpsend is the FQDN to connect to.

I think I found the problem. Now I had that file 'newsfeedb.domain.com' which 
was untouched, I could manipulate it by changing the relative spooldir to
absolute spooldir and copy it to 'serverb'. That worked!
I thought that innxmit (or nntpsend) would take the spooldir from 'inn.conf',
but it doesn't seem to. So now I have to play with symlinks or absolute
spooldir-names. Thanks anyway for the thinking ;-) The xtra file helped me
to open my eyes.

Eilko Bos.

More information about the inn-workers mailing list