History?

Zenon Panoussis oracle at xs4all.nl
Mon Aug 13 03:07:38 UTC 2001



I had some trouble getting INN to work back in February. Once 
I got it working, it was up and running smoothly until yesterday, 
when I f***ed up majorly. 

I deleted the db directory. I am aware that that was not a very 
smart move. 

Since everything was messed up anyway, I thought this was a good 
opportunity to install 2.3.2. I backed up the remaining news 
directories and installed the new version, then copied the spool 
from the 2.3.1 backup to the 2.3.2 active spool and did the same 
with everything that was actually configured in news/etc. So now 
I have all the articles and a new db/newsgroups, but no db/active, 
no history and no valid overview.

I tried makehistory and it protested that there was no active. 
Of course I have no idea what articles are in what newsgroups, 
so I made a dummy active with "safe" high and low marks, as in 
  newsgroup 1000000000 0000000001 n 
in the hope that this will force makehistory to read the spool. 

Then I run 
news at machine$ /usr/local/news/bin/makehistory -f history.n -O 

Nothing happens. makehistory creates a 0-byte history file 
and then exits immediately without any error message, without 
doing anything at all and without a trace in the logs. 

I tried the opposite way too: 

touch history
makedbz -i
mv history.n.dir history.dir
mv history.n.pag history.pag
makehistory -a -O

Nothing happens. 

So I am stuck. Any ideas what I'm doing wrong and how to 
recreate the db/* files? 

Z


-- 
oracle at everywhere: The ephemeral source of the eternal truth...


More information about the inn-workers mailing list