INNd overview corruption

Kim Alm kea at
Tue Nov 6 08:36:17 UTC 2001


For the record, I'm running inn on a Linux box, latest slackware with
kernel 2.4.12. All disks are reiserfs. And I was on innd 2.3.2 until
a couple of days ago, I'm now running 2.3.3 (20011103 prerelease).

On Mon, 5 Nov 2001 edk at wrote:
> We had a problem where INNd stopped showing all messages posted after a
> point two months in the past.  After looking around, I found
> instructions for recreating the overview, based on the theory that it
> might be the problem -- basically equivalent to the following:

I assume that these groups are not set to expire, but they where
still expired from the overview.

This sounds very much like what I ran into on in 2.3.2.

I was running tradspool and tradindexed.

Discovered one morning that a number of groups with very high
expire times had been expired from the overview, but the articles
where still on disk. Only way to get them back into the overview
was a rebuild. So I wiped most of my spool and ran a makehistory.

> bin/makehistory -b -f history.n -O -T/var/news/tmp -l 60000000
> I ran this last Friday, and then took a look at things.

Did you have any error messages from the rebuild of the overview?
I had some, don't remember the exact error messages, but it was
something like can't write IDX... file dosen't exist.

I found out that someone had reported similar problems previously
on the inn-workers list, and they had cured there problems by moving
to buffindexed. So I did a quick and dirty setup with buffindexed.

> db/active was clearly wrong, so I looked around and found the following
> command:
> bin/ctlinnd renumber ''

I have also been through hell with the active file, and I have no good
answer about this.

Buffindexed worked nicely for a couple of weeks (this was on 2.3.2), and
I started to receive messages like:

Oct 29 07:46:09 news expireover[17482]: buffindexed: ovgroupmmap ovbuff is
null(ovindex is 2357, ovblock is 825439285
Oct 29 07:46:09 news expireover[17482]: buffindexed: could not open overview
for ''

in the output from my daily. And the message was allways about the same
group, didn't take to much stress about it, becasue none of my readers
has so far shown any interest in that group. Had some sparetime and decided
to dig into inn-workers list once again and I found something
about a small bug in the buffindexed stuff, and that it might cause
more groups to fail.

That's when I decided to go for the latest STABLE snapshot, installed
it. Did a rmgroup, followed by a newgroup for that group.

Ran nicely for a couple of days, and I had the following:

Nov  4 08:39:13 news expireover[2502]: buffindexed: ovgroupmmap ovbuff is
null(ovindex is 13624, ovblock is 825439026
Nov  4 08:39:13 news expireover[2502]: buffindexed: could not mmap overview
for hidden groups(21504)

in my daily output yesterday, but no error messages this morning.

This is my story so far, does it sound like what you are experiencing?


More information about the inn-workers mailing list