Problem with inn-STABLE-20010828

The Doctor doctor at doctor.nl2k.ab.ca
Sat Sep 1 14:34:18 UTC 2001


On Fri, Aug 31, 2001 at 03:09:06AM +0900, Kenichi Okada wrote:
> In the message <7kvlmo9d at opaopa.org>
> Kenichi Okada <okada at opaopa.org> wrote:
> 
> 
> 
> > In the message <20010830090404.A15074 at doctor.nl2k.ab.ca>
> > The Doctor <doctor at doctor.nl2k.ab.ca> wrote:
> 
> > > And here is 20010830 report:
> > ..
> > > checking if OpenSSL is desired... yes
> > > checking for OpenSSL location... /usr/contrib
> > > checking for RSAPublicEncrypt in -lrsaref... no
> > > checking for BIO_new in -lcrypto... yes
> > > checking for SSL_library_init in -lssl... no
> > > configure: error: Can not find OpenSSL
> > > ns2.nl2k.ab.ca//usr/source/inn-STABLE-20010830$ cat config.log
> > > This file contains any messages produced by compilers while
> > > running configure, to aid debugging if configure makes a mistake.
> > ..
> > > configure:4155: checking for BIO_new in -lcrypto
> > > configure:4174: gcc -o conftest -g -O2   conftest.c -lcrypto  -lresolv -lutil  -L/usr/contrib/lib 1>&5
> > > configure:4196: checking for SSL_library_init in -lssl
> > > configure:4215: gcc -o conftest -g -O2   conftest.c -lssl -lcrypto  -lresolv -lutil  -L/usr/contrib/lib 1>&5
> > > /usr/contrib/lib/libcrypto.a(dso_dlfcn.o): In function `dlfcn_load':
> > > dso_dlfcn.o(.text+0xa7): undefined reference to `dlopen'
> > > dso_dlfcn.o(.text+0xb9): undefined reference to `dlopen'
> > > dso_dlfcn.o(.text+0x11d): undefined reference to `dlclose'
> > > /usr/contrib/lib/libcrypto.a(dso_dlfcn.o): In function `dlfcn_bind_var':
> > > dso_dlfcn.o(.text+0x1da): undefined reference to `dlsym'
> > > /usr/contrib/lib/libcrypto.a(dso_dlfcn.o): In function `dlfcn_bind_func':
> > > dso_dlfcn.o(.text+0x2aa): undefined reference to `dlsym'
> > > /usr/contrib/lib/libcrypto.a(dso_dlfcn.o): In function `dlfcn_unload':
> > > dso_dlfcn.o(.text+0x3a7): undefined reference to `dlclose'
> 
> > Thank you very much. I wanted this log.
> > The recent libcrypto needs libdl.
> > Please try the next patch.
> 
> % cd inn-STABLE-20010830
> % patch -p0 < {this patch}
> % autoconf
> % ./configure --with-openssl=/usr/contrib .......
> 
> > *** configure.in-orig	Fri Aug 31 01:28:09 2001
> > --- configure.in	Fri Aug 31 02:45:01 2001
> > ***************
> > *** 748,754 ****
> >   	    [AC_CHECK_LIB(RSAglue, RSAPublicEncrypt,
> >                             [SSL_LIB="-lRSAglue -lrsaref"], , -lrsaref)])
> >   	AC_CHECK_LIB(crypto, BIO_new,
> > ! 		     SSL_LIB="-lcrypto $SSL_LIB",
> >                        [AC_MSG_ERROR(Can not find OpenSSL)],
> >                        $SSL_LIB)
> >   	AC_CHECK_LIB(ssl, SSL_library_init,
> > --- 748,757 ----
> >   	    [AC_CHECK_LIB(RSAglue, RSAPublicEncrypt,
> >                             [SSL_LIB="-lRSAglue -lrsaref"], , -lrsaref)])
> >   	AC_CHECK_LIB(crypto, BIO_new,
> > !                      [AC_CHECK_LIB(dl, DSO_load,
> > ! 		                   SSL_LIB="-lcrypto -ldl $SSL_LIB",
> > ! 		                   SSL_LIB="-lcrypto $SSL_LIB",
> > !                                    -lcrypto -ldl $SSL_LIB)],
> >                        [AC_MSG_ERROR(Can not find OpenSSL)],
> >                        $SSL_LIB)
> >   	AC_CHECK_LIB(ssl, SSL_library_init,
> 
> 
> 
> 

Please add this patch into that Stable and Current.


This works for those of you who upgraded.


BTW when is 2.4.0 Beta coming?


More information about the inn-workers mailing list