Weird pgpverify problem

Mike Zanker mike-sender-6677e0 at zanker.org
Tue Apr 20 18:30:29 UTC 2004


OK, I've spent most of the afternoon trying to sort this out without
success so it's time to resort to the experts :)

I have two INN servers, one running INN 2.3.5 (Red Hat's own RPM 
supplied with Red Hat Enterprise Linux 3.0) and the other running INN 
2.4.1 (compiled by myself on Solaris 9).

The feeder (2.4.1) processes PGP-signed control messages fine. The 
reader (2.3.5) does not. The reader, in news.err, says

pgpverify: gpgv exited status 2 processing 
<1082426649.9341 at news.a3.xs4all.nl>
skipping newgroup nl-admin at nic.surfnet.nl (pgpverify failed) in
<1082426649.9341 at news.a3.xs4all.nl>

If I run pgpverify from the command line on that particular control
message, the output is "nl.newsgroups" on BOTH servers. So pgpverify 
seems to be working fine.

If I run "echo <path to control message> | controlchan" on each server, 
it works on the 2.4.1 server but fails on the 2.3.5 server. This seems 
to be because controlchan is trying to execute "sm -q <path to control 
message> |pgpverify" which fails because <path to control message> is 
not a token.

However, I think that may be a red herring. The real cause seems to be
that gpgv is exiting with status 2 when run via controlchan (but not 
when running pgpverify manually).

Any ideas?

Thanks,

-- 
Mike Zanker
Northampton, UK
PGP Public Key from pgp at zanker.org


More information about the inn-workers mailing list