INN 2.4.1 urgent release

Russ Allbery rra at stanford.edu
Wed Jan 7 23:42:55 UTC 2004


Russ Allbery <rra at stanford.edu> writes:

> Please let me know right away if there are any problems installing it
> over an existing INN 2.4 or STABLE installation.  Note that the security
> vulnerability should be fixed in this release and is *not* fixed in the
> current STABLE snapshots.

> CURRENT is also vulnerable; I just committed the fixes and hopefully the
> snapshots will update quickly.  For CURRENT users, here is the relevant
> patch:

I've now updated the STABLE and CURRENT snapshots with help from Peter
Losher, so you should be able to pull STABLE and CURRENT as of 20040107
and get versions with this fix.  I'm in a bit of a rush, so I just
regenerated the daily snapshots rather than incrementing the version
number; sorry about that.  Life will return to normalcy with the snapshots
as of tonight.

-- 
Russ Allbery (rra at stanford.edu)             <http://www.eyrie.org/~eagle/>

    Please send questions to the list rather than mailing me directly.
     <http://www.eyrie.org/~eagle/faqs/questions.html> explains why.


More information about the inn-workers mailing list