lock method used for buffindexed

Russ Allbery rra at stanford.edu
Mon Jan 12 00:17:29 UTC 2004

Ron Jarrell <jarrell at solaris.cc.vt.edu> writes:

> I've been having the same problem with binding too, I just hadn't had a
> chance to deal with it.  Happy to see this thread, so I know I'm not the
> only one!  Something's definitely broken in portability between 2.4.0
> and 2.4.1...

I'm not sure what you're thinking of.  Nothing that we've been talking
about is a difference between 2.4.0 and 2.4.1.

> I had 2.4.0 running for some time on a somewhat reasonably patched
> solaris 8.  I tried to build both a recent stable, and a recent current
> (well, recent when I grabbed then and built them initially pre-xmas...),
> and in both cases, innbind or inndstart (as appropriate) swore they
> didn't have permission to bind to port 119, despite clearly being setuid
> to root, and with nothing else funky on the system.

I have no idea on this.  I run my main INN servers on Solaris 8, and I've
never seen any sign of these problems.  I'm running 2.4.1 happily on that
platform now.

Russ Allbery (rra at stanford.edu)             <http://www.eyrie.org/~eagle/>

    Please send questions to the list rather than mailing me directly.
     <http://www.eyrie.org/~eagle/faqs/questions.html> explains why.

More information about the inn-workers mailing list