lock method used for buffindexed

Ron Jarrell jarrell at solaris.cc.vt.edu
Mon Jan 12 05:08:13 UTC 2004

At 10:10 PM 1/11/2004, Russ Allbery wrote:
>I've double-checked and yes, the system on where innbind didn't work 
>now running fine with inndstart, so I think you're running into two
>separate problems somehow.

I downloaded stable-20040112, recompiled from scratch again, blew away 
my install tree, (except the db dir and the ldap auth module I added) 
and tried again.  It worked this time.  Must have been some leftover 
from the multiple installs that I didn't catch.

But the other problem I'd been having with 2.4.1 didn't go away.. When 
someone *successfully* authenticates against the server with my ldap 
auth module, nnrpd throws a sigbus.  If they blow it, they get the 02 
authentication error.  I replaced the 2.4.2 nnrpd with the 2.4.0 nnrpd, 
and it works fine.  I compiled them the same way (literally, I cut and 
pasted out of the config.status file...)

signal BUS (invalid address alignment) in CMDauthinfo at 0x2c2dc
0x0002c2dc: CMDauthinfo+0x0230: ld      [%o0 + 0x82], %o1

(although under gdb it segfaults instead..)

Program received signal SIGSEGV, Segmentation fault.
0x2c2dc in CMDauthinfo (ac=1521664, av=0x1822d8) at commands.c:250
250                 if (LLOGenable) {

I notice that LLOGenable is defined in nnrpd.c as a bool, but is an 
extern int everywhere else...
I changed it to an extern bool and the problems went away.

More information about the inn-workers mailing list