STABLE + FreeBSD: Corrupted history file

Matti Saarinen mjs at
Tue Mar 30 07:48:58 UTC 2004

I've had several problems with our new news server which is an
Intel-based box (IBM x345) running FreeBSD. Most of the problems have
been harware related but now innd has died couple of times with the
following message:

innd: SERVER can't open history /news/db/history: Numerical argument out of domain

This has happened while expire has been running. I've been able to
start the server again by running by hand.

The history file is over 2 GB and INN has been compiled with large
file support.

I managed to reduce the size of the history file below 2 GB and tried
to start innd. It still died with the same error message.

At the moment, I'm running makehistory, which in its turn is logging
the following error messages

makehistory: dbzstore duplicate message-id history.n:[A638FED211E8CB237C0884BC45331508]@26084562 Invalid argument

The questions:

Is FreeBSD broken in some way that inn cannot be run on the top of it?

Could it be that FreeBSD's soft updates are the cause of this problem?
I've enabled soft upfates on ~news/db file system.

Or have I hit some memory addressing problem that is related to 32 bit
CPUs and even smaller memory address size?


- Matti -

More information about the inn-workers mailing list