inn-stable on HP/UX

Guy FELTIN Guy.Feltin at
Wed May 26 07:16:49 UTC 2004

Dans son message, Heath Kehoe ecrivait :

 > I had not run any version of INN since 2.3.something on HP/UX until
 > just recently, when I built STABLE and fired it up.  It looks to be
 > working correctly, with one exception:  The history.hash and
 > history.index files are not getting updated on-disk by innd (the
 > modified time-stamps aren't changing (or changing sporadically),
 > and lookups via nnrpd or grephistory are failing).
 > This is the classic symptom of using mmap without msync on HP/UX.
 > And indeed, lsof says that innd has history.hash and history.index
 > mmap'ed.
 > But what puzzles me is that 2.3.x doesn't have this problem.  I
 > grepped the 2.3 source for msync, and there are no msync calls in
 > the history code.  So: either 2.3 did not mmap those files; or
 > everything accessing history mmap'ed those files.
 > What might have changed to cause this behaviour?  I guess I'll have
 > to fire up 2.3 again, and see if the hash and index files are
 > mmap'ed.

I have the same problem, I run inn-2.3.4 and It works fine,
but when I try inn-2.4.1 and inn-STABLE-200405xx and 
I run makehistory :
makehistory -b -l 30000 -I
with my no empty spool the history files are empty.

-rw-r--r--   1 usenet     news             0 May 26 08:26 history
-rw-r--r--   1 usenet     news            43 May 26 08:26 history.dir
-rw-r--r--   1 usenet     news             0 May 26 08:26 history.hash
-rw-r--r--   1 usenet     news             0 May 26 08:26 history.index

HPUX-11.11 and gcc-3.3.2

  Guy  Feltin   -   03 83 68 24 30

More information about the inn-workers mailing list