stop/start causes hang in Perl script

Jeffrey M.Vinocur jeff at litech.org
Sat Oct 16 02:06:29 UTC 2004


On Oct 15, 2004, at 5:39 PM, Felix E. Klee wrote:

> Sorry, I forgot that.  Here's a usual output:
>
> 1
> 2 Stopping innd:
>
> Sometimes it continues after some time, though.  Recently, I got this
> output:
>
> 1
> 2 Stopping innd: .
> 3 Starting innd.
> Scheduled start of /usr/lib/news/bin/innwatch.
> innwatch: [18146] locked by [17959]
>
>> When it hangs, is the server still running?
>
> The daemon innd is still running.  An example recorded during a hang:
>
> ~> ps aux|grep -i innd
> news     18195  0.1  1.9  7796 3680 ?        S    23:31   0:00 
> /usr/lib/news/bin/innd -p 3

And when it hangs, what happens if you telnet to the server (port 119)? 
  What if you try running `ctlinnd mode`?

I've never seen this before, but it sounds a little bit like there's 
something wrong with the .pid files stored in PATHRUN, almost as if the 
shutdown script is seeing the wrong PIDs when it looks.

If you look there just before trying to restart, are the PIDs in 
innd.pid and innwatch.pid the same as you see in `ps`?


> Can you reproduce the problem?

I haven't tried.

I'm still a little puzzled by the fact that it doesn't happen when you 
run the stop/start commands manually, though.  (You've tried that 
enough times to know it's not coincidence?)


-- 
Jeffrey M. Vinocur
jeff at litech.org



More information about the inn-workers mailing list