SSL connection timeouts

Russ Allbery rra at stanford.edu
Tue Jun 7 05:56:59 UTC 2005


Sebastian Wiesinger <inn at tracker.fire-world.de> writes:
> * Toon van der Pas <toon at hout.vanvergehaald.nl> [2005-03-23 22:43]:

>> We are running an usenet news server, where we allow users to connect
>> directly and without any form of authentication and encryption from
>> within our network, but force users to connect via SSL and authenticate
>> themselves from the outside.
>> 
>> Mozilla will hang when posting messages via an SSL-encrypted link.  It
>> doesn't happen always. It appears to happen when writing the message
>> takes a little while. When the message is written and sent quickly,
>> mozilla doesn't hang.
>> 
>> We are running inn-STABLE-20041230, but the problem was there with
>> earlier versions also.

> I can confirm this Problem with INN 2.4.2 and slrn. If I connect and try
> to post, slrn just hangs until I kill it. At the moment I use stunnel as
> a workaround(posting works fine) but I would like to see that problem
> fixed, too. IP-Based authentication does not work with stunnel because
> everyone connects to nnrpd from localhost.

I'd love to see it fixed too, but I have absolutely no idea where to start
looking on this one.  If anyone can track it down, I'd really appreciate
it.  I really don't understand the current nnrpd SSL code (and keep
thinking there's got to be an easier way to implement it).

-- 
Russ Allbery (rra at stanford.edu)             <http://www.eyrie.org/~eagle/>

    Please send questions to the list rather than mailing me directly.
     <http://www.eyrie.org/~eagle/faqs/questions.html> explains why.


More information about the inn-workers mailing list