INN 2.4.1 on OpenBSD 3.6: inndstart setgroups

Glen Miner shaggie76 at hotmail.com
Mon Mar 14 16:04:16 UTC 2005


I'm trying to get INN 2.4.1 running on OpenBSD 3.6. This transcript says it 
all:

></home/news/bin> id
>uid=0(root) gid=0(wheel) groups=0(wheel), 2(kmem), 3(sys), 4(tty),
>     5(operator), 20(staff), 31(guest)
>
></home/news/bin> ls -l inndstart -r-sr-x---  1 root  news  107995 Mar 11 
>17:40 inndstart*
>
></home/news/bin> su - news -c /home/news/bin/rc.news
>Starting innd.
>inndstart: can't setgroups (is inndstart setuid root?):
>     Operation not permitted
>inndstart: can't seteuid to 0:
>     Operation not permitted
>Scheduled start of /home/news/bin/innwatch.

I've read the INN FAQ and double checked its recommendatations under "3.1. 
INN won't start after a new installation." I've even tried various 
combinations of setuid -- (ie: setuid but not setgid). And, of course, I 
even tried running it as root. I suspect, however, that there is some 
additional setuid restriction on OpenBSD that is causing problems.

Any advice or suggestions would be appreciated!

peace




More information about the inn-workers mailing list