Windows Live Mail rejecting GROUP response

Julien ÉLIE julien at trigofacile.com
Mon Jun 4 21:15:32 UTC 2012


Hi Matt,

Thanks for your fast reply about that subject.


> Agreed. I've raised the issue on Microsoft's support forum. I am
> told  they are taking a look at it, but I have not received confirmation that
> this is a bug in Windows Live Mail

Incidentally, do you see the same behaviour on more recent versions of INN?

You can try to point Windows Live Mail to news.trigofacile.com if you wish.

% telnet news.trigofacile.com 119
200 news.trigofacile.com InterNetNews NNRP server INN 2.6.0 (20120528 
prerelease) ready (no posting)
GROUP fr.test
211 7278 8228 18399 fr.test
QUIT
205 Bye!

I believe you should not see any problem with such sessions.  Could you 
please have a look?



> Hmm, I just notices there is one more reply from the INN server
> following the GROUP reply. But I don't see a corresponding request
> from WLMail, so I'm not sure what this additional reply means.

This superfluous 205 answer has been fixed in INN 2.5.1:
     http://inn.eyrie.org/trac/changeset/8614



> 200 snews InterNetNews NNRP server INN 2.4.3 ready (posting ok).
> MODE READER
> 200 snews InterNetNews NNRP server INN 2.4.3 ready (posting ok).
> GROUP cisco.eng.cdets-trolls
> 211 6907 1 6910 cisco.eng.cdets-trolls
> [FIN, ACK] Seq=44 Ack=173 Win=65528 Len=0
> 205 .

INN should not have sent the 205 reply here.  Maybe it the reason why 
Windows Live Mail complained!

If you follow up on the discussion in the Microsoft forums, please ask 
them to properly send a QUIT command!

-- 
Julien ÉLIE

« Quoi qu'elle fasse, la femme doit le faire deux fois mieux que
   l'homme pour qu'on en pense autant de bien. Heureusement, ce n'est pas
   difficile. » (Charlotte Whitton)


More information about the inn-workers mailing list