Libtool now unconditional in INN CURRENT

Russ Allbery rra at
Wed May 30 18:12:43 UTC 2012

Julien ÉLIE <julien at> writes:

> I found out with "ldconfig -v" that the libraries were redirected this
> way:

> ->
> ->
> ->

We've had this problem before.  I think we have a bug report or comment
somewhere, but I couldn't find it in a quick check.  The problem is that
our backup suffix for shared libraries looks to ldconfig like just part of
the SONAME and one that actually makes the .OLD libraries sort later than
the new ones, so it links to the wrong one.

Not creating backups of the shared libraries would fix this.  Updating our
shared library versions properly on any change would also fix this,
although that's a lot of updates if we were going to try to keep the
versions accurate for snapshots.

> It shows that the new installed version uses the .OLD files!
> Strange…
> I ran "make update" a second time, which solved the problem.  INN then
> started fine.

Yes, that would have replaced the *.OLD libraries with another copy of the
new libraries.  I bet that the links are still pointing to *.OLD.

Russ Allbery (rra at             <>

    Please send questions to the list rather than mailing me directly.
     <> explains why.

More information about the inn-workers mailing list