Today's patches

Julien ÉLIE julien at trigofacile.com
Tue May 5 19:11:05 UTC 2015


Hi Richard,

> /* A magic number for the group.index file so that we can later change the
>    format in a backward-compatible fashion. */
> #define TDX_MAGIC       (~(0xf1f0f33d))
> 
> Why is it defined in the inverse?  i.e. why not the much clearer:
> 
> #define TDX_MAGIC 0x0e0f0cc2

I admit I do not know.  Leaving this as-is does no harm, though.


> Subject: [PATCH 1/3] Initialize ARTHANDLE objects before passing by
> value
> Subject: [PATCH 3/3] Correct remap check in tradindexed group lookup

Both committed.  Thanks!



> Subject: [PATCH 2/3] Remove redundant (broken!) code
> 
> The check was (i) off by one and (ii) can never happen, given the
> loop condition.

At the end of the loop, we have:

        parent = &entry->next.recno;
        current = *parent;

Can't we imagine that the group index still has not been remaped
after the creation of a new newsgroup (therefore situated at index->count)?
Then, index->count is the next.recno and we should check that the same way
you did for patch #3.

"while (current >= 0)" only and check whether "current >= index->count"?

Wouldn't it make sense to do that?

-- 
Julien ÉLIE

« Et devant cette levée de boucliers, moi, je lève le camp ! »
  (Astérix)


More information about the inn-workers mailing list