SIGSEGV when running innd as non-root user

Julien ÉLIE julien at
Fri Jan 27 06:56:00 UTC 2017

Hi Dominik,

Do you still see that bug with INN 2.6.1?

I believe the following commit fixed it:


-------- Message d'origine --------
De : Dominik 'Rathann' Mierzejewski <dominik at> 
Date : 26/01/2017  23:19  (GMT+01:00) 
À : inn-workers at 
Objet : SIGSEGV when running innd as non-root user 

Dear list,
I'm one of the maintainers of the INN package in Fedora. A bug report
came some time ago about a segfault when running innd as non-root user:

It's easy to reproduce, too. Just run the command as non-root user:
INNCONF=/tmp/inn.conf /usr/libexec/news/innd -d

According to the report above:
[...] it segfaults in newsuser.c:98.
It crashes because innconf variable is NULL and this is because innd
calls ensure_news_grp() via ensure_news_user_grp() before reading a
configuration with innconf_read() in main().

The issue is that the target user and group is defined in the
configuration file. The get_news_uid_gid() default to hard-coded "news"
group if configuration is not yet loaded.

Would it be possible to modify innd so that it first reads
configuration, and then it tries to change UID and GID?

Best regards,

PS. I tried opening a trac ticket first, but I don't see any option
to create an account there (
"Faith manages."
        -- Delenn to Lennier in Babylon 5:"Confessions and Lamentations"
inn-workers mailing list
inn-workers at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the inn-workers mailing list