hissqlite

Russ Allbery eagle at eyrie.org
Wed Dec 30 18:10:45 UTC 2020


Bo Lindbergh <2bfjdsla52kztwejndzdstsxl9athp at gmail.com> writes:
> I myself wrote:

>> Step 1 seems to be merging and refactoring history/buildconfig
>> and storage/buildconfig since they apparently do the same thing
>> except with different names.

> It got pretty abstract.  What's a good, short noun we can attach
> to the meaning "thing that can be implemented by multiple methods"?
> As in "The three ___s are storage, history, and overview."

Modular components?  That sounds a bit clunky.

Plugins?  Not that we've done any of the work required to make it a real
plugin system, but that's kind of the vague direction in which it went.

-- 
Russ Allbery (eagle at eyrie.org)             <https://www.eyrie.org/~eagle/>

    Please send questions to the list rather than mailing me directly.
     <https://www.eyrie.org/~eagle/faqs/questions.html> explains why.


More information about the inn-workers mailing list